centOS 升级 php 5.3 到 5.6

2018-04-10 13:59:00
IDO老徐
原创
238

前几天,需要在服务器,部署一套wiki ,但php版本过低 。

所以,需要升级php版本。

如下是升级的过程记录 ,给到需要的同学 。


/


 

1.查看已经安装的php版本号

php -v


出现下面代码: 

1
2
3
PHP 5.3.3 (cli) (built: Jul 9 2015 17:39:00)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

嗯,可以看到,当前服务器的php版本是5.3

我们继续。



2.安装Remi跟EPEL RPM源

如果你还没安装,则输入以下代码: 

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm && rpm -Uvh epel-release-latest-6.noarch.rpm 

wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm && rpm -Uvh remi-release-6*.rpm



下载之后:

nano /etc/yum.repos.d/remi.repo

 

然后对里面内容进行以下修改:

1
2
3
4
5
6
7
[remi]
name=Remi's RPM repository for Enterprise Linux 6 - $basearch
#baseurl=http://rpms.remirepo.net/enterprise/6/remi/$basearch/
mirrorlist=http://rpms.remirepo.net/enterprise/6/remi/mirror
enabled=0    #IDO老徐 备注,改成 0 
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

 

还有以下: 

1
2
3
4
5
6
7
8
[remi-php56]
name=Remi's PHP 5.6 RPM repository for Enterprise Linux 6 - $basearch
#baseurl=http://rpms.remirepo.net/enterprise/6/php56/$basearch/
mirrorlist=http://rpms.remirepo.net/enterprise/6/php56/mirror
# WARNING: If you enable this repository, you must also enable "remi"
enabled=1   #IDO老徐备注,改成 1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

按CTRL+O保存,CTRL+X关闭编辑器



3.现在可以yum命令直接升级了


输入以下代码

yum -y upgrade php*



一旦更新完毕,再次查看php版本号 

php -v


出现以下信息 

1
2
3
PHP 5.6.35 (cli) (built: Mar 29 2018 07:37:47) 
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies


 到此,php升级完毕 。



End 

文章分类
热门文章
公众号2



想了解更多 ?

欢迎关注老徐的公众号

Tester & 职场人 & 5W人都在关注

技术文 & 职场文 & 进阶文 & 动态 

第一时间,更新至此公众号

简尚公众号

长按二维码/微信扫码  关注老徐

老徐私人微信isTester

有问题,随时留言


联系老徐
联系人: IDO老徐
Email: 957863300@qq.com
QQ: 957863300
微信: isTester
微博: isTester
网址: isTester.com
地址: 中国 . 广东 . 深圳